快捷搜索:

思科ASA防火墙配置

要想设置设置设备摆设摆设思科的防火墙得先懂得这些敕令:

常用敕令有:nameif、interface、ip address、nat、global、route、static等。

global

指定公网地址范围:定义地址池。

Global敕令的设置设置设备摆设摆设语法:

global (if_name) nat_id ip_address-ip_address [netmark global_mask]

此中:

(if_name):表示外网接口名称,一样平常为outside。

nat_id:建立的地址池标识(nat要引用)。

ip_address-ip_address:表示一段ip地址范围。

[netmark global_mask]:表示全局ip地址的收集掩码。

nat

地址转换敕令,将内网的私有ip转换为外网公网ip。

nat敕令设置设置设备摆设摆设语法:nat (if_name) nat_id local_ip [netmark]

此中:

(if_name):表示接口名称,一样平常为inside.

nat_id:表示地址池,由global敕令定义。

local_ip: 表示内网的ip地址。对付0.0.0.0表示内网所有主机。

[netmark]:表示内网ip地址的子网掩码。

route

route敕令定义静态路由。

语法:

route (if_name) 0 0 gateway_ip [metric]

此中:

(if_name):表示接口名称。

0 0 :表示所有主机

Gateway_ip:表示网关路由器的ip地址或下一跳。

[metric]:路由花费。缺省值是1。

static

设置设置设备摆设摆设静态IP地址翻译,使内部地址与外部地址逐一对应。

语法:

static(internal_if_name,external_if_name) outside_ip_addr inside_ ip_address

此中:

internal_if_name表示内部收集接口,安然级别较高,如inside。

external_if_name表示外部收集接口,安然级别较低,如outside。

outside_ip_address表示外部收集的公有ip地址。

inside_ ip_address表示内部收集的本地ip地址。

(括号内序顺是先内后外,外边的顺序是先外后内)

例如:

asa(config)#static (inside,outside) 133.0.0.1 192.168.0.8

表示内部ip地址192.168.0.8,造访外部时被翻译成133.0.0.1全局地址

奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫奸淫**

asa#conf t

asa(config)# hostname asa//设置主机名

asa(config)#enable password cisco//设置密码

设置设置设备摆设摆设外网的接口,名字是outside,安然级别0,输入ISP给您供给的地址就行了。

asa(config)#interface GigabitEthernet0/0

asa(config)#nameif outside//名字是outside

asa(config)#securit-level 0//安然级别0

asa(config)#ip address *.*.*.* 255.255.255.0//设置设置设备摆设摆设公网IP地址

asa(config)#duplex full

asa(config)#

asa(config)#no shutdown

设置设置设备摆设摆设内网的接口,名字是inside,安然级别100

asa(config)#interface GigabitEthernet0/1

asa(config)#nameif inside

asa(config)#securit-level 100

asa(config)#duplex full

asa(config)#speed 100

asa(config)#no shutdown

设置设置设备摆设摆设DMZ的接口,名字是dmz,安然级别50

asa(config)#interface GigabitEthernet0/2

asa(config)#nameif dmz

asa(config)#securit-level 50

asa(config)#duplex full

asa(config)#

asa(config)#no shutdown

收集部分设置

asa(config)#nat(inside) 1 192.168.1.1 255.255.255.0

asa(config)#global(outside) 1 222.240.254.193 255.255.255.248

asa(config)#nat (inside) 0 192.168.1.1 255.255.255.255//表示192.168.1.1这个地址不必要转换。直接转发出去。

asa(config)#global (outside) 1 133.1.0.1-133.1.0.14//定义的地址池

asa(config)#nat (inside) 1 0 0//0 0表示转换网段中的所有地址。定义内部收集地址将要翻译成的全局地址或地址范围

设置设置设备摆设摆设静态路由

asa(config)#route outside 0 0 133.0.0.2//设置默认路由133.0.0.2为下一跳

假如内部网段不是直接接在防火墙内口,则必要设置设置设备摆设摆设到内部的路由。

asa(config)#Route inside 192.168.10.0 255.255.255.0 192.168.1.1 1

地址转换

asa(config)#static (dmz,outside) 133.1.0.1 10.65.1.101;静态NAT

asa(config)#static (dmz,outside) 133.1.0.2 10.65.1.102;静态NAT

asa(config)#static (inside,dmz) 10.66.1.200 10.66.1.200;静态NAT

假如内部有办事器必要映射到公网地址(外网造访内网)则必要static

asa(config)#static (inside, outside) 222.240.254.194 192.168.1.240

asa(config)#static (inside, outside) 222.240.254.194 192.168.1.240 10000 10//后面的10000为限定连接数,10为限定的半开连接数

ACL实现策略造访

asa(config)#access-list 101 permit ip any host 133.1.0.1 eq www;设置ACL

asa(config)#access-list 101 permit ip any host 133.1.0.2 eq ftp;设置ACL

asa(config)#access-list 101 deny ip any any;设置ACL

asa(config)#access-group 101 in interface outside;将ACL利用在outside端口

当内部主机造访外部主机时,经由过程nat转换成公网IP,造访internet。

当内部主机造访中心区域dmz时,将自己映射成自己造访办事器,否则内部主机将会映射成地址池的IP,到外部去找。

当外部主机造访中心区域dmz时,对133.0.0.1映射成10.65.1.101,static是双向的。

PIX的所有端口默认是关闭的,进入PIX要颠末acl进口过滤。

静态路由唆使内部的主机和dmz的数据包从outside口出去。

您可能还会对下面的文章感兴趣: